sábado, 16 de agosto de 2014

Create a linux boot USB with OS X



1. Download the ISO you want

http://www.ubuntu.com/download/desktop

2. Insert the USB

3. Press Comand+space

4. Type "disk utility"

5. Select the USB

6. Click on erase

7. Go to Partition

8. Select 1 partition in the volume scheme

9. Go to options and make sure the GUID  Partition Table is selected.

10. Also make sure that the format is Mac OS Extended (journaled)

11. Download the iso you want to install, in my case I have ubuntu 14.04:

$ ls -l *.iso
-rw-r--r--@ 1 user  staff  1010827264 Jun 23 15:11 ubuntu-14.04-desktop-amd64.iso


12. Convert your iso to the right format. I am naming it ubu14.img
$ hdiutil convert -format UDRW -o ubu14.img ubuntu-14.04.1-desktop-amd64.iso
Reading Driver Descriptor Map (DDM : 0)…
Reading Ubuntu 14.04.1 LTS amd64         (Apple_ISO : 1)…
Reading Apple (Apple_partition_map : 2)…
Reading Ubuntu 14.04.1 LTS amd64         (Apple_ISO : 3)…
..............................................................................................................................................................
Reading EFI (Apple_HFS : 4)…
..............................................................................................................................................................
Reading Ubuntu 14.04.1 LTS amd64         (Apple_ISO : 5)…
....................................................................................................................................................................
Elapsed Time:  1m 25.631s
Speed: 11.5Mbytes/sec
Savings: 0.0%
created: /Users/user/Downloads/ubu14.img.dmg

13. You might se a .dmg extension attached to your converted file, in my case it is ubu14.img.dmg

$ ls ubu*
ubu14.img.dmg ubuntu-14.04-desktop-amd64.iso ubuntu-14.04.1-desktop-amd64.iso


14. Identify your USB device in this case /dev/disk1

$ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS MacOSX                  300.0 GB   disk0s2
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *7.8 GB     disk1
   1:                        EFI                         209.7 MB   disk1s1
   2:                  Apple_HFS Untitled 1              7.5 GB     disk1s2


15. Umount your USB device:

$ diskutil umountDisk /dev/disk1
Unmount of all volumes on disk1 was successful

16. Write the iso to the usb

$ sudo dd if=ubu14.img.dmg of=/dev/rdisk1 bs=1m
Password:
981+0 records in
981+0 records out
1028653056 bytes transferred in 224.304496 secs (4585967 bytes/sec)

17. You might see a warning saying that the device is not readable, dont do anything you will close it later.

18. List and umount

$ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS MacOSX                  300.0 GB   disk0s2
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     Apple_partition_scheme                        *7.8 GB     disk1
   1:        Apple_partition_map                         4.1 KB     disk1s1
   2:                  Apple_HFS                         2.4 MB     disk1s2

$ diskutil umountDisk /dev/disk1
Unmount of all volumes on disk1 was successful


19. Then click on ignore on the warning dialog that says your device was not readable.

Finally remove your USB, it is ready to be used as a boot USB.

Enjoy!

P.S. Ubuntu flag?

No hay comentarios:

Publicar un comentario